

<!DOCTYPE html >
<html lang="en"  xmlns:fb="http://ogp.me/ns/fb#"> 
<head>
	
	<!-- Load Story -->
	
	

<script>var setupRequestType = "StoryPage";</script>


		

<!-- Begin: MetaTags -->


<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge"> 
<meta name="viewport" content="width=device-width, initial-scale=1">



	
	<meta property="fb:app_id" content="438127646217909" />
	<meta property="og:title" content="Update on the latest news, sports, business and entertainment at 9:20 a.m. EDT" />
	<meta property="og:type" content="article" />
	<meta property="og:site_name" content="ABC 6 NEWS" />
	<meta property="og:description" content="Facing public backlash, Postmaster General Louis DeJoy is set to testify Friday about disruptions in mail delivery." />
	<meta property="og:url" content="https://www.KAALtv.com/news/update-on-the-latest-news-sports-business-and-entertainment-at-920-am-edt/5834861/" />
	
	<meta name="DC.date.issued" content="2020-08-21">

    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@ABC6NEWS">
    <meta name="twitter:title" content="Update on the latest news, sports, business and entertainment at 9:20 a.m. EDT">
    <meta name="twitter:description" content="Facing public backlash, Postmaster General Louis DeJoy is set to testify Friday about disruptions in mail delivery.">
	
    	<meta name="twitter:image" content="https://www.KAALtv.com/kaalimages/repository/2020-08/mgn1280x72000818b00-suqqu.jpg">
	
			
			
			<meta property="og:image" content="https://www.KAALtv.com/kaalimages/repository/2020-08/mgn1280x72000818b00-suqqu.jpg" />
			<meta property="og:image:width" content="800" /> <meta property="og:image:height" content="450" />			
			<link rel="image_src" type="image/jpeg" href="https://www.KAALtv.com/kaalimages/repository/2020-08/mgn1280x72000818b00-suqqu.jpg" />
			<meta name="thumbnail" content="https://www.KAALtv.com/kaalimages/repository/2020-08/mgn1280x72000818b00-suqqu.jpg" />
			
		
		<meta http-equiv="Refresh" content=900 />
	
		<meta name="description" content="Facing public backlash, Postmaster General Louis DeJoy is set to testify Friday about disruptions in mail delivery." />
	
	<meta name="robots" content="FOLLOW,INDEX" />

	<link rel="amphtml" href="https://amp.kaaltv.com/articles/update-on-the-latest-news-sports-business-and-entertainment-at-920-am-edt-5834861.html"> 

	<link rel="canonical" href="https://www.KAALtv.com/news/update-on-the-latest-news-sports-business-and-entertainment-at-920-am-edt/5834861/" />

	
    <!-- ZETA Script -->
    
	
	

    <script>
    var site_id='kaal-hubbard-tv';
    (function(b,t,r,a,i,n){b['bt']=b['bt']||function(){(b['_bt']=b['_bt']||[]).push(arguments);},i=t.createElement(r),n=t.getElementsByTagName(r)[0];i.async=1;i.src=a;n.parentNode.insertBefore(i,n);})(window,document,'script','https://cdn.boomtrain.com/p13n/'+site_id+'/p13n.js');
    </script>        
        
    <meta property="bt:id" content="5834861" /> 
	<meta property="bt:pubDate" content="2020-08-21T08:33:41-06:00" />
	<meta property="bt:modDate" content="2020-08-21T08:33:41-06:00" />
	<meta property="bt:category" content="news" />
	<meta property="bt:section" content="Front Page" />
	
    <!-- ZETA -->
        
    
      
    

<link rel="icon" href="/favicon.ico?v=2" />

<link rel="icon" type="image/png"  href="/apple-touch-icon-57x57.png">

<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/favicon-194x194.png" sizes="194x194">
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-TileImage" content="/mstile-144x144.png">
<meta name="theme-color" content="#ffffff">

<meta name="apple-itunes-app" content="app-id=521167681">
<meta name="google-play-app" content="app-id=com.doapps.android.mln.MLN_e4c7991c840bd4665a1f9c72441b069c">
<link rel="apple-touch-icon" href="https://s3.amazonaws.com/static.mobilelocalnews.com/images/app_1195/branding/1195_icon_1024.png">
<link rel="android-touch-icon" href="https://s3.amazonaws.com/static.mobilelocalnews.com/images/app_1195/branding/1195_icon_1024.png"/>



<!-- End: MetaTags -->

    <script type="application/ld+json">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</script>

		<!-- 3/26/2020 -->
<script async src="//js-sec.indexww.com/ht/p/186967-36752780642041.js"></script>
<!-- END: 3/26/2020 -->

<link rel="stylesheet" type="text/css" href="/assets/css/hubbard-min.css">
<link rel="stylesheet" type="text/css" href="/assets/css/brand.css">
<link rel="stylesheet" type="text/css" href="/assets/css/hbi.css">
<script type="text/javascript" src="/assets/js/bower.js"></script>
<script type="text/javascript" src="/assets/js/hubbard-min.js"></script>
<script src='//www.google.com/jsapi' type='text/javascript'></script> <!-- Google Search --->
<script type="text/javascript" src="/assets/js/DFP-DebugFlag.js"></script>
<script type="text/javascript" src="/2016/widgets/2016-WXWIDGET.js"></script>
<script type="text/javascript" src="/assets/js/DFP-VirtualDirectories.js"></script>
<script type="text/javascript" src="/assets/js/DFP-SEOSlugs.js"></script>
<script type="text/javascript" src="/assets/js/DFP-ExtractCategory.2020.js"></script>
<script type="text/javascript" src="/assets/js/DFP-CatAdUnitWeb31.2016.js"></script>
<script type="text/javascript" src="/assets/js/DFP-OverrideAdUnitWeb31.2016.js"></script>
<script type="text/javascript" src="/assets/js/DFP-CatAllowTagsWeb31.2016.js"></script>
<script type="text/javascript" src="/assets/js/DFP-Header.js"></script>
<script type="text/javascript" src="/2016/widgets/HBI-weatherWidgetDefault.js"></script>
<script type="text/javascript" src="/assets/js/HBI-weatherWidget.js"></script>
<script type="text/javascript" src="/assets/js/HBI-storyTimes.js"></script>
<script type="text/javascript" src="/assets/js/ANVATO-Setup-Script.js"></script>
<script type="text/javascript" src="/2016/scripts/ANVATO-Setup-Category-Xref-Playlist.js"></script>

<!-- Added on 1/6/2020 KC request. -->
<script src="https://scripts.webcontentassessor.com/scripts/89cbc00ba3b8695bc12f3511d5a373c71d013b6ece5a813c39bba8e761b6fd41"></script>

<!-- Begin WSI Interactive Radar loader script -->
<!---<script type="text/javascript" src="https://webwidgets.wsi.com/?cid=654566225"></script>--->
<!-- End WSI Interactive Radar loader script -->


        <!-- BEGIN: 2016-3rd-Party-Header -->

<!-- Begin Taboola Tag Header -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/hubbard-kaal/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<!-- End Taboola Tag Header -->


<!-- 02/12/2020  -->
<script data-ad-client="ca-pub-8087073732553662" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<!-- Begin Next Millennium -->
<script async src="https://powerad.ai/script.js"></script>
<!-- End Next Millennium -->

        
    
	    <title>Update on the latest news, sports, business and entertainment at 9:20 a.m. EDT | KAALTV.com</title>
	
</head>
<body>

<!-- Main Navigation -->
<header class="header-top">
	
<!-- Topbar (Rushmore) -->
  
  <div class="topbar visible-md visible-lg">
    <div class="row">
      <div class="col-xs-12">
        <a class="pull-left" href="/">
          <img class="logo" src="/assets/images/weblogos.png" alt="ABC 6 News">
        </a>
        
	        <!-- Start: 2016-WEATHER-WIDGET-DESK -->
<a id="weatherWidgetLinkToDesk" href="/weather/">
<div id="desktopWeatherWidget" class="pull-right hidden-xs hidden-sm hbi-weather-widget-dsk">
	<div class="row">
		<div class="col-xs-4">
            <div class="row">
                <div class="col-xs-3 hbi-weather-widget-align hbi-weather-widget-icon-desk" id="currIconDesk"></div>        		
                <div class="col-xs-4 hbi-weather-widget-align hbi-weather-widget-temp-desk" id="currTempDesk"></div>        		
                <div class="col-xs-5 hbi-weather-widget-vari-desk text-nowrap" id="currVariDesk">
	                Feels like: <span id="currFeelsLike"></span>
                    <br />Humidity: <span id="currHumidity"></span>
                    <br />Wind speed: <span id="currWindSpeed"></span>
                </div>        		
			</div>
            <div class="row">
                <div class="col-xs-12 hbi-weather-widget-desc-desk text-center" id="currDescDesk"></div>        		
			</div>
        </div>
		<div class="col-xs-1">
		</div>
		<div class="col-xs-4">
            <div class="row">
                <div class="col-xs-6">
                    <div class="row">
                        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-icon1-desk" id="secondIconDesk"></div>        		
                        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-desc1-desk" id="secondTempDesk"></div>        		
                    </div>
                </div>
                <div class="col-xs-6">
                    <div class="row">
                        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-icon1-desk" id="thirdIconDesk"></div>        		        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-desc1-desk" id="thirdTempDesk"></div>                    </div>
                </div>
			</div>
             <div class="row">
                <div class="col-xs-12 hbi-weather-widget-sponsord">
					<div id="WXWIDGET" class="col-xs-12 text-center">
<script>googletag.cmd.push(function() {googletag.display('WXWIDGET');});</script> 
</div>

                </div>
             </div>
        </div>    
		<div class="col-xs-3">
            <div class="row">
                <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-icon-desk" id="tomorrowIconDesk"></div>        		
                <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-desc2-desk">
                	<div>Tomorrow</div>
                    <div id="tomorrowTempDesk"></div>
                </div>        		
			</div>
        </div>
    </div>
</div>
</a>
<!-- End: 2016-WEATHER-WIDGET-DESK -->

        
      </div>
    </div>
  </div>
  <!-- Close Topbar -->
<!-- Start: NAV-DESK -->
  <nav class="navbar navbar-default navbar-desktop visible-md visible-lg">
    <!-- Main Menu -->
    <ul class="nav navbar-nav navbar-left">
        
	        <div id="navbar" class="navbar-collapse collapse">
	<ul class="nav navbar-nav">
		<li class="dropdown">
			<a href="/" aria-haspopup="true" aria-expanded="false">NEWS<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/local-news/" class="hbi-nav-a">Local</a></li>
				<li><a href="/minnesota-news/" class="hbi-nav-a">Minnesota</a></li>
				<li><a href="/iowa/" class="hbi-nav-a">Iowa</a></li>
				<li><a href="/georgefloyd/" class="hbi-nav-a">George Floyd</a></li>
				<li><a href="/abc6news-tonight/" class="hbi-nav-a">ABC 6 News Tonight</a></li>
				<li><a href="/national-news/" class="hbi-nav-a">National</a></li>
				<li><a href="/election/" class="hbi-nav-a">Election 2020</a></li>
				<li><a href="/special-reports/" class="hbi-nav-a">Special Reports</a></li>
				<li><a href="/business/" class="hbi-nav-a">Business</a></li>
				<li><a href="/entertainment/" class="hbi-nav-a">Entertainment</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/coronavirus/" aria-haspopup="true" aria-expanded="false">CORONAVIRUS<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/news/coronavirus-resources/5668960/" class="hbi-nav-a">Resources</a></li>
				<li><a href="/article/13145/" class="hbi-nav-a">Closures</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/assignment-ed/" aria-haspopup="true" aria-expanded="false">ASSIGNMENT EDUCATION <span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/education-news/area-back-to-school-plans-for-2020-2021/5816461/?cat=12218" class="hbi-nav-a">Return to Learn Plans</a></li>
				<li><a href="/assignment-ed/" class="hbi-nav-a">Education Headlines</a></li>
				<li><a href="/school-at-home/" class="hbi-nav-a">School at Home</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/weather/" aria-haspopup="true" aria-expanded="false">WEATHER<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/article/10152/" class="hbi-nav-a">Forecast</a></li>
				<li><a href="/radar/" class="hbi-nav-a">Radar</a></li>
				<li><a href="/article/10211/" class="hbi-nav-a">Watches & Warnings</a></li>
				<li><a href="/weather/ultimate-severe-weather-guide/5726618/?cat=10151" class="hbi-nav-a">Ultimate Severe Weather Guide</a></li>
				<li><a href="/article/13145/" class="hbi-nav-a">Closures & Delays</a></li>
				<li><a href="/pages/weather-cams/abc-6-news---rochester.shtml" class="hbi-nav-a">Towercams</a></li>
				<li><a href="/traffic-cams/" class="hbi-nav-a">Traffic Cams</a></li>
				<li><a href="/article/12457" class="hbi-nav-a">Map Room</a></li>
				<li><a href="/pages/weather-spotters/signup.shtml" class="hbi-nav-a">Weather Spotters</a></li>
				<li><a href="/weatherlab/" class="hbi-nav-a">Weather Lab</a></li>
				<li><a href="/weatherphotos/" class="hbi-nav-a">Submit Your Weather Photos</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/live/" aria-haspopup="true" aria-expanded="false">WATCH<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/live/" class="hbi-nav-a">Live Streaming</a></li>
				<li><a href="/article/10209/" class="hbi-nav-a">On-Air Schedule</a></li>
				<li><a href="https://thistv.com/" class="hbi-nav-a" target="_blank">This TV 6.2</a></li>
				<li><a href="https://abc.com/" class="hbi-nav-a" target="_blank">ABC Network</a></li>
				<li><a href="/article/stories/S3745196.shtml" class="hbi-nav-a">Children's Programming</a></li>
				<li><a href="/article/stories/S468963.shtml" class="hbi-nav-a">Closed Captioning</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/sports/" aria-haspopup="true" aria-expanded="false">SPORTS<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/prepathlete/" class="hbi-nav-a">Prep of the Week</a></li>
				<li><a href="/sportszone/" class="hbi-nav-a">Sports Zone</a></li>
				<li><a href="/gotw/" class="hbi-nav-a">Game of the Week</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/6onyourside/" aria-haspopup="true" aria-expanded="false">COMMUNITY<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/pages/misc/birthday-club.shtml" class="hbi-nav-a">Birthday Club</a></li>
				<li><a href="/assignment-ed/" class="hbi-nav-a">Assignment Education </a></li>
				<li><a href="/open-for-business/" class="hbi-nav-a">Open for Business</a></li>
				<li><a href="/spark" class="hbi-nav-a">Ignite Spark</a></li>
				<li><a href="/partner/" class="hbi-nav-a">Partners</a></li>
				<li><a href="/event-guide/" class="hbi-nav-a">Events Calendar</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/links/" aria-haspopup="true" aria-expanded="false">LINKS<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/pages/newsletter/signup.shtml" class="hbi-nav-a">Email Newsletter</a></li>
				<li><a href="/trivia/" class="hbi-nav-a">Morning Trivia</a></li>
				<li><a href="/links/" class="hbi-nav-a">Featured Links</a></li>
				<li><a href="https://lb.511mn.org/mnlb/roadreports/routeselect.jsf?current=true&view=southeast&text=m&textOnly=false" class="hbi-nav-a" target="_blank">MnDOT Construction</a></li>
				<li><a href="/spotcrime/" class="hbi-nav-a">Spot Crime</a></li>
				<li><a href="/article/10280" class="hbi-nav-a">Ag Reports</a></li>
			</ul>
		</li>
		<li class="dropdown">
			<a href="/contact/" aria-haspopup="true" aria-expanded="false">CONTACT<span class="caret"></span></a>
			<ul class="dropdown-menu">
				<li><a href="/news-tips/" class="hbi-nav-a">Submit a News Tip</a></li>
				<li><a href="/news-team/" class="hbi-nav-a">News Team</a></li>
				<li><a href="/sales-team/" class="hbi-nav-a">Sales Team</a></li>
				<li><a href="/advertise/" class="hbi-nav-a">Advertise</a></li>
				<li><a href="/article/13105/" class="hbi-nav-a">Mobile App</a></li>
				<li><a href="https://hubbardbroadcasting.com/" class="hbi-nav-a">Careers</a></li>
			</ul>
		</li>
	</ul>
</div>
<style>
.dropdown-menu {
width: auto !important;
padding: 10px !important;
left: auto !important;
}
</style>

            
    </ul>
    <!-- Close Main Menu -->

    <!-- Navbar Right -->
    <ul class="nav navbar-nav navbar-right">
        <a href='/article/10157/'>
          <img src='/2016/images/search.png' />
        </a>
    </ul>
    <!-- Close Navbar Right -->

    <!-- Search Box -->
    <div class="navbar-search">
      <div class="input-group">
         <div class="search searchbox floatright margin-bottom-sml">
         
			<!-- BEGIN GOOGLE SEARCH BOX -->
<!-- test -->

<script>
	(function() {
		var cx = '006970377737801590391:c_awnuku8hg';
		var gcse = document.createElement('script');
		gcse.type = 'text/javascript';
		gcse.async = true;
		gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(gcse, s);
	})();
</script>
<gcse:searchbox-only></gcse:searchbox-only>

<style>
	/* Set the line height of the search box text input so it doesn't hide the bottom line of the search box border */
	.gsc-input {
		height: 100% !important;
		line-height: 1.0 !important;
	}
</style>

<!-- END GOOGLE SEARCH BOX -->

		  
        </div>  
        <span class="input-group-btn">
          <a class="btn btn-default search-btn-close">
            <span class="glyphicon glyphicon-remove"></span>
          </a>
        </span>
      </div>
    </div>
    <!-- Close Search Box -->
  </nav>
<!-- End: NAV-DESK -->

	<!-- Start: NAV-MOBI -->
  <!-- Mobile Nav -->
  <nav id="sticky-header" class="navbar navbar-default navbar-desktop navbar-fixed-top navbar-fixed-offscreen">
    <!-- Navbar Header -->
    <div class="navbar-header">
      <!-- Mobile Only Menu Button -->
      <a class="mega-nav-btn btn btn-link pull-right mobile-menu-button visible-xs" href="#">
        MENU
        <span class="glyphicon glyphicon-menu-hamburger"></span>
        <span class="glyphicon glyphicon-remove hidden"></span>
      </a>
      
          <!-- Small Weather Widget -->
	 	<!-- Start: 2016-WEATHER-WIDGET-MOB -->
<div id="mobileWeatherWidget" class="hidden-sm hidden-md hidden-lg hbi-weather-widget-mob">
	<div class="row">
		<div class="col">
            <div class="row">
				<a href="/weather/" class="weatherMobileWidget">
                <div class="col-xs-6 col-sm-2 hbi-weather-widget-align hbi-weather-widget-icon-mob" id="currIconMob"></div>       		
                <div class="col-xs-6 col-sm-2 hbi-weather-widget-align hbi-weather-widget-temp-mob" id="currTempMob"></div>
                </a>
			</div>
        </div>
    </div>    
</div>
<!-- End: 2016-WEATHER-WIDGET-MOB -->

    	<!-- Close Small Weather Widget -->

      
      <!-- Mobile Only Menu Button -->
      <a class="navbar-brand" href="/">
        <img src="/assets/images/weblogosMobile.png" alt="ABC 6 News">
      </a>
    </div>
    <!-- Close Navbar Header -->

    <!-- Desktop / Tablet Navbar Menu -->
    <ul class="nav navbar-nav navbar-right hidden-xs">
      <li>
        <a class="search-btn mobile-menu-button">
          <span class="glyphicon glyphicon-search"></span>
        </a>
      </li>
      <li>
        <a class="mega-nav-btn mobile-menu-button">
          MENU
          <span class="glyphicon glyphicon-menu-hamburger"></span>
          <span class="glyphicon glyphicon-remove hidden"></span>
        </a>
      </li>
    </ul>
    <!-- Close Desktop / Tablet Navbar Menu -->

    <!-- Small Weather Widget -->
 	<!-- Start: 2016-WEATHER-WIDGET-TAB -->
<div id="TableWeatherWidget" class="center-block hidden-xs hbi-weather-widget-tab">
	<div class="row">
		<div class="col">
            <div class="row">
				<a href="/weather/">
                <div id="currIconTab" class="col-sm-3 hbi-weather-widget-align hbi-weather-widget-icon-tab"></div>        		
                <div id="currTempTab" class="col-sm-3 hbi-weather-widget-align hbi-weather-widget-temp-tab"></div>        		
                <div id="currDescTab" class="col-sm-6 hbi-weather-widget-align hbi-weather-widget-desc-tab"></div>        		
				</a>
			</div>
        </div>
    </div>    
</div>
<!-- End: 2016-WEATHER-WIDGET-TAB -->

    <!-- Close Small Weather Widget -->

    <!-- Search Box -->
    <div class="navbar-search">
      <div class="input-group">
        <!-- BEGIN GOOGLE SEARCH BOX -->

<script>
	(function() {
		var cx = '006970377737801590391:c_awnuku8hg';
		var gcse = document.createElement('script-tbl');
		gcse.type = 'text/javascript';
		gcse.async = true;
		gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
		var s = document.getElementsByTagName('script-tbl')[0];
		s.parentNode.insertBefore(gcse, s);
	})();
</script>
<gcse:searchbox-only></gcse:searchbox-only>

<style>
	/* Set the line height of the search box text input so it doesn't hide the bottom line of the search box border */
	.gsc-input {
		height: 100% !important;
		line-height: 1.0 !important;
	}
</style>

<!-- END GOOGLE SEARCH BOX -->

        <span class="input-group-btn">
          <a class="btn btn-default search-btn-close">
            <span class="glyphicon glyphicon-remove"></span>
          </a>
        </span>
      </div>
    </div>
    <!-- Close Search Box -->

    <!-- Mobile Mega Nav -->
    <div class="mega-nav hidden">
      <div class="navbar-desktop">
        <!-- Mobile Search -->
        <div class="form-group visible-xs">
			<!-- BEGIN CLOUDSEARCH BUTTON -->

<a href='/article/10157/'>
  <img src='/2016/images/search.png' />
</a>

<!-- END CLOUDSEARCH BUTTON -->

        </div>
        <!-- Close Mobile Search -->
        
		<div class="mega-nav-row" style="padding-bottom: 55px;">
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/" class="text-uppercase">NEWS</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/local-news/">Local</a></li>
			<li class="hbi-mobil-menu-item"><a href="/minnesota-news/">Minnesota</a></li>
			<li class="hbi-mobil-menu-item"><a href="/iowa/">Iowa</a></li>
			<li class="hbi-mobil-menu-item"><a href="/georgefloyd/">George Floyd</a></li>
			<li class="hbi-mobil-menu-item"><a href="/abc6news-tonight/">ABC 6 News Tonight</a></li>
			<li class="hbi-mobil-menu-item"><a href="/national-news/">National</a></li>
			<li class="hbi-mobil-menu-item"><a href="/election/">Election 2020</a></li>
			<li class="hbi-mobil-menu-item"><a href="/special-reports/">Special Reports</a></li>
			<li class="hbi-mobil-menu-item"><a href="/business/">Business</a></li>
			<li class="hbi-mobil-menu-item"><a href="/entertainment/">Entertainment</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/coronavirus/" class="text-uppercase">CORONAVIRUS</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/news/coronavirus-resources/5668960/">Resources</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/13145/">Closures</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/assignment-ed/" class="text-uppercase">Assignment Education </a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/education-news/area-back-to-school-plans-for-2020-2021/5816461/?cat=12218">Return to Learn Plans</a></li>
			<li class="hbi-mobil-menu-item"><a href="/assignment-ed/">Education Headlines</a></li>
			<li class="hbi-mobil-menu-item"><a href="/school-at-home/">School at Home</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/weather/" class="text-uppercase">WEATHER</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/article/10152/">Forecast</a></li>
			<li class="hbi-mobil-menu-item"><a href="/radar/">Radar</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/10211/">Watches & Warnings</a></li>
			<li class="hbi-mobil-menu-item"><a href="/weather/ultimate-severe-weather-guide/5726618/?cat=10151">Ultimate Severe Weather Guide</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/13145/">Closures & Delays</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/weather-cams/abc-6-news---rochester.shtml">Towercams</a></li>
			<li class="hbi-mobil-menu-item"><a href="/traffic-cams/">Traffic Cams</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/12457">Map Room</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/weather-spotters/signup.shtml">Weather Spotters</a></li>
			<li class="hbi-mobil-menu-item"><a href="/weatherlab/">Weather Lab</a></li>
			<li class="hbi-mobil-menu-item"><a href="/weatherphotos/">Submit Your Weather Photos</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/live/" class="text-uppercase">WATCH</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/live/">Live Streaming</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/10209/">On-Air Schedule</a></li>
			<li class="hbi-mobil-menu-item"><a href="https://thistv.com/" target="_blank">This TV 6.2</a></li>
			<li class="hbi-mobil-menu-item"><a href="https://abc.com/" target="_blank">ABC Network</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/stories/S3745196.shtml">Children's Programming</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/stories/S468963.shtml">Closed Captioning</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/sports/" class="text-uppercase">SPORTS</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/prepathlete/">Prep of the Week</a></li>
			<li class="hbi-mobil-menu-item"><a href="/sportszone/">Sports Zone</a></li>
			<li class="hbi-mobil-menu-item"><a href="/gotw/">Game of the Week</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/6onyourside/" class="text-uppercase">COMMUNITY</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/pages/misc/birthday-club.shtml">Birthday Club</a></li>
			<li class="hbi-mobil-menu-item"><a href="/assignment-ed/">Assignment Education </a></li>
			<li class="hbi-mobil-menu-item"><a href="/open-for-business/">Open for Business</a></li>
			<li class="hbi-mobil-menu-item"><a href="/spark">Ignite Spark</a></li>
			<li class="hbi-mobil-menu-item"><a href="/partner/">Partners</a></li>
			<li class="hbi-mobil-menu-item"><a href="/event-guide/">Events Calendar</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/links/" class="text-uppercase">LINKS</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/pages/newsletter/signup.shtml">Email Newsletter</a></li>
			<li class="hbi-mobil-menu-item"><a href="/trivia/">Morning Trivia</a></li>
			<li class="hbi-mobil-menu-item"><a href="/links/">Featured Links</a></li>
			<li class="hbi-mobil-menu-item"><a href="https://lb.511mn.org/mnlb/roadreports/routeselect.jsf?current=true&view=southeast&text=m&textOnly=false" target="_blank">MnDOT Construction</a></li>
			<li class="hbi-mobil-menu-item"><a href="/spotcrime/">Spot Crime</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/10280">Ag Reports</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/contact/" class="text-uppercase">CONTACT</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/news-tips/">Submit a News Tip</a></li>
			<li class="hbi-mobil-menu-item"><a href="/news-team/">News Team</a></li>
			<li class="hbi-mobil-menu-item"><a href="/sales-team/">Sales Team</a></li>
			<li class="hbi-mobil-menu-item"><a href="/advertise/">Advertise</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/13105/">Mobile App</a></li>
			<li class="hbi-mobil-menu-item"><a href="https://hubbardbroadcasting.com/">Careers</a></li>
		</ul>
	</div>
</div>

		
      </div>
    </div>
    <!-- Close Mobile Mega Nav -->
  </nav>
<!-- End: NAV-MOBI -->

  

<!-- Start: WSI-SCRIPT-CALL -->
<script>buildWeatherWidget();;</script>
<!-- End: WSI-SCRIPT-CALL -->

    <!-- Start: 2016-quicklinks -->
<div class="custom-links visible-lg visible-md">
	<div class="alert alert-info quicklinks-info">
		<div class="hbi-quicklinks-alert-desc">QUICK LINKS: </div>
		<a href="/live" class="hbi-quicklinks-alert-link">Watch Now</a> | 
		<a href="/pages/weather-cams/abc-6-news---rochester.shtml" class="hbi-quicklinks-alert-link">Tower Cams</a> | 
		<a href="/article/13177/" class="hbi-quicklinks-alert-link">Traffic Cams</a> | 
		<a href="http://kaaltv.com/article/13105/" class="hbi-quicklinks-alert-link">Download App</a>
	</div>
</div>
<!-- End: 2016-quicklinks -->


</header>
<!-- Close Main Navigation -->
<!-- Main Container -->
<div class="container">
	<!-- Begin alert row -->
    <!-- Load Alerts -->

    <!-- No active alerts for our area -->
<!-- last update: 08/21/2020 1:00:40 PM -->
<!-- No live video scheduled -->
<!-- 08/21/2020 1:01:01 PM -->

<!-- updated 8/21/2020 1:00:00 PM -->



    
<!-- End Load Alerts -->



	<!-- Endalert row -->	
	<!-- Begin Header Section Row -->	
    <div class="row">  
    
    
        <div id="ADSPACE01" class="ad-top-wrapper"><script>googletag.cmd.push(function() {googletag.display('ADSPACE01');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    
    </div>  
	<!-- End Header Section Row -->	
    <!-- Main Content and Sidebar Section -->
    <div class="row">
        <!-- Main Content Column-->
        <div class="col col-offset-right-300">
            <!-- White Panel -->
            <div class="panel panel-default">
                <!-- Begin First Row -->
                <div class="row hbi-row-padding">
                  <!-- Start: Story Page  2016-e-mc-07-rcb-v2 -->

<!-- 08/26/2019  DAF Added the Enhace Extended functionality. -->


	
	<div class="col">
		<div class="row">
			<div class="col-md-10 col-md-offset-1">
				<div class="panel-body hbi-story-panel-body-before-ad">
					<h1 class="hbi-h1">Update on the latest news, sports, business and entertainment at 9:20 a.m. EDT
</h1>
					<div class="row story-body">
						<div class="col ">
							
									<p><img class="img-responsive" src="/kaalimages/repository/2020-08/mgn1280x72000818b00-suqqu.jpg" alt="Update on the latest news, sports, business and entertainment at 9:20 a.m. EDT">
									 
									
										<span class="hbi-story-media-credit">Photo: USPS. </span>
									</p>
								
						</div>
					</div>
					<div class="row story-body">
						<div class="col">
							<p class="hbi-story-credits-p" style="line-height: 1.3em;">
								
								
									<span>KAAL-TV</span><br />
								
									<small style="font-weight: normal; font-style: italic; font-size: 12px;">
									
										Created: August 21, 2020 08:33 AM 
									</small>
								
								<br clear="all">
							</p>
						</div>
					</div>
					<div class="row story-body hbi-story-body">
						<div class="col-xs-12">
						<p>Postmaster to testify in Senate on mail, Mnuchin denies role<br />
&nbsp;&nbsp;<br />
WASHINGTON (AP) - Facing public backlash, Postmaster General Louis DeJoy is set to testify Friday about disruptions in mail delivery. A Senate committee is expected to dig into changes made ahead of the November election, just as millions of Americans are expected to vote by mail. Democrats warn DeJoy&rsquo;s cost-cutting initiatives are causing an upheaval that threatens voting. President Donald Trump raised the stakes by saying he wants to block funds. Treasury Secretary Steve Mnuchin says he had no role in DeJoy&rsquo;s selection. Republican Sen. Ron Johnson, the chairman of the Senate Homeland Security committee, is expected to dismiss the &ldquo;false political narrative&rdquo; that DeJoy is trying to &ldquo;sabotage&rdquo; the election, according to prepared remarks.<br />
&nbsp;&nbsp;<br />
Pence criticizes DNC, previews themes for RNC convention<br />
&nbsp;&nbsp;<br />
Vice President Mike Pence says next week&rsquo;s Republican Party convention &ldquo;will make sure the American people see the choice&rdquo; between President Donald Trump and Democrat Joe Biden. Previewing themes for the Republican gathering, Pence told several morning talk shows Friday that viewers of next week&#39;s RNC will hear about how the GOP will support law and order, and the men and women of law enforcement. Democrats wrapped their four-day convention Thursday night after nominating Biden for president and California Sen. Kamala Harris for vice president. Pence called the DNC&#39;s virtual convention &ldquo;negative&rdquo; and says he couldn&#39;t watch much of it.<br />
&nbsp;&nbsp;<br />
Biden vows to defeat Trump, end US &#39;season of darkness&#39;<br />
&nbsp;&nbsp;<br />
WILMINGTON, Del. (AP) - Joe Biden has accepted the Democratic presidential nomination, vowing to take on national crises and declaring that &ldquo;we will overcome this season of darkness.&rdquo; Biden&#39;s nomination marks the pinnacle - so far - of a political career that has spanned almost a half-century. The former vice president at 77 years old would be the oldest president ever elected. Biden was saluted by former Democratic foes as he became the party&#39;s official standard bearer for the campaign against President Donald Trump in November. Biden focused on uniting the deeply divided nation as Americans grapple with a monthslong health crisis, related economic devastation and a national awakening on racial justice.&nbsp;<br />
&nbsp;&nbsp;<br />
Portland clashes rage again outside US immigration building<br />
&nbsp;&nbsp;<br />
PORTLAND, Ore. (AP) - Protesters in Oregon&rsquo;s largest city have clashed again with federal agents outside a U.S. Immigrations and Customs Enforcement building that has become a new focus of the demonstrations that have gripped Portland for months. Portland police say people in a group of about 100 late Thursday and early Friday sprayed the building with graffiti, hurled rocks and bottles at agents and shined laser lights at them. The Oregonian/OregonLive reported that the agents set off smoke or tear gas and used crowd control munitions in response. Police say three people were arrested. The protests have happened nightly since the police killing of George Floyd in Minneapolis.<br />
&nbsp;&nbsp;<br />
Minneapolis plans to rent space to replace burned precinct<br />
&nbsp;&nbsp;<br />
MINNEAPOLIS (AP) - The city of Minneapolis plans to spend $4.8 million to temporarily rent an office building and adapt it to replace the precinct headquarters that burned during unrest following the death of George Floyd. A City Council committee on Thursday approved spending $3.6 million to sublease the building for three years and $1.2 million to renovate it. The building is about a half-mile from the 3rd Precinct headquarters that burned May 28 after officers were ordered to evacuate. Officers and staff have been working remotely and at the Minneapolis Convention Center since then. Floyd, a handcuffed Black man, died May 25 after a white Minneapolis police officer pressed his knee against Floyd&rsquo;s neck for nearly eight minutes.<br />
&nbsp;&nbsp;<br />
2 Caribbean storms pose potential hurricane threats to US<br />
&nbsp;&nbsp;<br />
MEXICO CITY (AP) - Two tropical depressions at opposite ends of the Caribbean are projected to become tropical storms - perhaps even hurricanes - and forecasters say both might hit the United States after drenching much of the region. Tropical Depression 14 was nearing the coast of Honduras Friday morning. The U.S. National Hurricane Center says it&#39;s expected to veer northwest and cut across the tip of Mexico&rsquo;s Yucatan Peninsula Sunday, possibly at or near hurricane force. Tropical Depression 13 is nearing the northern Leeward islands. Forecasters say it&#39;s disorganized and might degenerate. But it also could blow up into a major hurricane.<br />
&nbsp;&nbsp;<br />
California fires claim 5 lives, threaten thousands of homes<br />
&nbsp;&nbsp;<br />
SANTA CRUZ, Calif. (AP) - Wildfires that have claimed at least five lives and forced tens of thousands of people from their homes continue to blaze around California. Three major collections of fires are threatening tens of thousands of homes in the San Francisco Bay Area and central California. More evacuations are expected as hot and gusty weather continues into Friday. State fire officials say at least four civilians have died in the fire areas, possibly including a Pacific Gas &amp; Electric worker. And a helicopter pilot on a water-dropping mission died in a crash Wednesday.&nbsp;<br />
&nbsp;&nbsp;<br />
White House to take rare turn as host of memorial service<br />
&nbsp;&nbsp;<br />
WASHINGTON (AP) - Sometimes politics gives way to the personal at the White House. It has seen 18 weddings and at least 10 people are known to have died there, including two presidents and three first ladies. It will serve Friday as a place of mourning for President Donald Trump and his family with a private memorial service for the president&rsquo;s younger brother, Robert, who passed away at 71. The president has described Robert as not just his brother but his &quot;best friend.&rdquo; Anita McBride, who served in three presidential administrations, including as first lady Laura Bush&#39;s chief of staff, says it is completely within the president&rsquo;s ability to honor him with a service there and that the White House serves a complex mission as an office, a museum and a home.<br />
&nbsp;&nbsp;<br />
German doctors gain access in Siberia to dissident in coma<br />
&nbsp;&nbsp;<br />
MOSCOW (AP) - Family and allies of Russian opposition leader Alexei Navalny are fighting to get him moved to German clinic from the Siberian hospital where he has been in a coma for over 24 hours. Local doctors in Russia refused to authorize the transfer, saying the 44-year-old politician&rsquo;s condition was too unstable. Navalny is one of President Vladimir Putin&rsquo;s fiercest critic. He was admitted to an intensive care unit in the Siberian city of Omsk on Thursday, following what his supporters are calling a suspected poisoning that they believe was engineered by the Kremlin. A plane with German specialists and all the necessary equipment to take Navalny to Berlin landed at Omsk airport on Friday.<br />
&nbsp;&nbsp;<br />
Iran says US has no right to demand restoration of sanctions<br />
&nbsp;&nbsp;<br />
TEHRAN, Iran (AP) - Iran&rsquo;s foreign minister has sent a letter to the U.N. Security Council saying the U.S. has no right to demand the restoration of U.N. sanctions against Iran. According to the Foreign Ministry&rsquo;s website on Friday, Mohammad Javad Zarif said the U.S. lost the right to make demands in 2018 when it withdrew from the nuclear deal between Iran and major world powers. He also said America&rsquo;s unilateral pullout violated a U.N. resolution that required signatories to avoid any damage to the deal. U.S. Secretary of State Mike Pompeo on Thursday officially informed the U.N. it is demanding the restoration of all U.N. sanctions on Iran, but allies and opponents declared the U.S. action illegal and doomed to failure.</p>

<p>(Copyright 2020 The Associated Press. &nbsp;All rights reserved. This material may not be published, broadcast, rewritten or redistributed.)</p>

						</div>
					</div>
				</div>
			</div> 
		 </div>
		<div class="row visible-xs visible-sm">
			<div class="col" style="margin-bottom:10px;">
				
        <div id="ADSPACE02" class=""><script>googletag.cmd.push(function() {googletag.display('ADSPACE02');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
           
			</div>
		</div>
		<div class="row">
			<div class="col-md-10 col-md-offset-1">
				<div class="panel-body hbi-story-panel-body-after-ad">
					
						<div class="row story-body hbi-story-body">
							<div class="col-xs-12">
							

<p>8/21/2020 8:20:11 AM (GMT -5:00)</p>  
							</div> 
						</div> 
					
						<p class="hbi-story-copy-p"><br />(Copyright 2020 by The Associated Press. All Rights Reserved.)</p>
					
				</div>                
			</div>
		</div>
		
		
		
		
		
		<div class="panel-body">
			<div class="row story-body hbi-story-body">
				<div class="col-md-11 col-md-offset-1">
					<div class="addthis_sharing_toolbox"></div>
					<script type="text/javascript" 
					src="http://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-57daef8617aecc6a">
					</script>
				</div>
			</div>
		</div>
		
		
			<div class="panel-body">
				<div class="row story-body">
					<div class="col-md-10 col-md-offset-1">
						<a class="btn btn-primary" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww%2EKAALtv%2Ecom%2Fnews%2Fupdate%2Don%2Dthe%2Dlatest%2Dnews%2Dsports%2Dbusiness%2Dand%2Dentertainment%2Dat%2D920%2Dam%2Dedt%2F5834861%2F&display=popup&ref=plugin&src=like&kid_directed_site=0&app_id=107596302633663" target="_blank" role="button" style="font-size: 11px;">Comment on Facebook</a>
						<button type="button" class="btn" data-toggle="modal" data-target="#commentModal" style="background-color: #cccccc; font-size: 11px;">Comment to ABC 6 News</button>
						<!-- Modal -->
						<div class="modal fade" id="commentModal" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true">
							<div class="modal-dialog" role="document">
								<div class="modal-content">
									<div class="modal-header">
										<button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">x</span><span class="sr-only">Close</span></button>
									</div>
									<div class="modal-body">
										<div id="wufoo-z16rsa430chvk9a">
											Form not loading? <a href="https://abc6news.wufoo.com/forms/z16rsa430chvk9a" target="_blank">Click here</a>
										</div>
										<div id="wufoo-z16rsa430chvk9a"> 
											Fill out my <a href="https://abc6news.wufoo.com/forms/z16rsa430chvk9a">online form</a>. 
										</div>
										<script type="text/javascript">
										$('#commentModal').on('show.bs.modal', function () {
											var z16rsa430chvk9a; (function(d, t) { 
											var s = d.createElement(t), options = { 
												'userName':'abc6news', 
												'formHash':'z16rsa430chvk9a', 
												'autoResize':true, 
												'height':'751', 
												'async':true, 
												'host':'wufoo.com', 
												'header':'show', 
												'defaultValues':'field8=https://www.KAALtv.com/news/update-on-the-latest-news-sports-business-and-entertainment-at-920-am-edt/5834861/',
												'ssl':true}; 
											s.src = ('https:' == d.location.protocol ?'https://':'http://') + 'secure.wufoo.com/scripts/embed/form.js'; 
											s.onload = s.onreadystatechange = function() { 
												var rs = this.readyState; if (rs) if (rs != 'complete') if (rs != 'loaded') return; 
												try { z1mfo19g076aqam = new WufooForm(); z1mfo19g076aqam.initialize(options); z1mfo19g076aqam.display(); } catch (e) { } }; 
												var scr = d.getElementsByTagName(t)[0], par = scr.parentNode; par.insertBefore(s, scr); 
											})(document, 'script');
										})
										</script>
									</div>
									<div class="modal-footer">
										<button type="button" class="btn btn-secondary" data-dismiss="modal">Close</button>
									</div>
								</div>
							</div>
						</div>
						<!-- End Modal -->
					</div>
				</div>
			</div>
		
		
		<div class="panel-body">
			<div class="row story-body">
				<div class="col-md-10 col-md-offset-1">
					<div class="row">
						<div class="col-lg-7" style="margin: 0 !important; padding: 0 !important; float-left: !important;">
							
							<div style="padding-bottom: 10px;"> 
        <div id="ADSPACE03" class="col-md-6"><script>googletag.cmd.push(function() {googletag.display('ADSPACE03');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    </div>  
						</div>
						<div class="col-lg-5">
							<div id="boomtrain-recommends-side-bar"></div>
						</div>
					</div>
				</div>
			</div>
		</div>
		
		<div class="panel-body">
			<div class="row story-body">
				<div class="col-md-10 col-md-offset-1">
					<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>
				</div>
			</div>
		</div>
		
	</div>


<!-- End: CUSTOM - 2016-E-MC-07 - Story Page --> 
                </div>
                <!-- End Last Row -->  
            </div> 
            <!-- Close White Panel -->
        </div>
 		 	    
        <!-- End Main Content Column --> 
        <!-- SideBar Column -->    
        <div class="col col-fixed-300 visible-lg visible-md"> 
			
            <!-- Begin Header Section Row -->
                
        <div id="ADSPACE04" class=""><script>googletag.cmd.push(function() {googletag.display('ADSPACE04');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    
            <!-- Begin Header Section Row -->
                
<!-- Start: E-SB-2 -->
	<div class="panel panel-default">
	        
       	            <!-- Content Block 31 686 -->
<div class="panel panel-default">
	<div class="panel-heading">
		<h3 class="panel-title text-uppercase text-muted">Most Read Stories</h3>
	</div>
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/rochester-minnesota-news/search-warrant-leads-to-recovery-of-drugs-and-cash/5834926/">Search warrant leads to recovery of drugs and $40K in cash</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/rochester-minnesota-news/search-warrant-leads-to-recovery-of-drugs-and-cash/5834926/">
			<img class="media-object" src="/kaalimages/repositoryThumbs/2020-08/siewert.jpg" alt="Search warrant leads to recovery of drugs and $40K in cash" width="88" height="50">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/rochester-minnesota-news/crash-on-hwy-52-backs-up-traffic/5834841/">Crash on Hwy 52 in Rochester backs up traffic</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/rochester-minnesota-news/crash-on-hwy-52-backs-up-traffic/5834841/">
			<img class="media-object" src="/kaalimages/repositoryThumbs/2020-08/hwy-52-crash.png" alt="Crash on Hwy 52 in Rochester backs up traffic" width="88" height="50">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/rochester-minnesota-news/suspect-arrested-in-prostitution-investigation/5834922/">Suspect arrested in prostitution investigation</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/rochester-minnesota-news/suspect-arrested-in-prostitution-investigation/5834922/">
			<img class="media-object" src="/kaalimages/repositoryThumbs/2020-08/pitchford.jpg" alt="Suspect arrested in prostitution investigation" width="88" height="50">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/rochester-minnesota-news/hydroxychloroquine-health-coronavirus-politics-medicine-lawmaker/5832089/">VIDEO: MN senator and physician has a message for the governor</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/rochester-minnesota-news/hydroxychloroquine-health-coronavirus-politics-medicine-lawmaker/5832089/">
			<img class="media-object" src="/kaalimages/repositoryThumbs/2020-08/VIDEO_MN_senator_and_physician_has_a_message_for_the_governor-syndImport-083256.jpg" alt="VIDEO: MN senator and physician has a message for the governor" width="88" height="50">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/coronavirus/south-dakota-officials-warn-of-covid-19-exposure-at-sturgis/5834140/">South Dakota officials warn of COVID-19 exposure at Sturgis</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/coronavirus/south-dakota-officials-warn-of-covid-19-exposure-at-sturgis/5834140/">
			<img class="media-object" src="/kaalimages/repositoryThumbs/2020-08/mgn1280x72000808p00-mxffj.jpg" alt="South Dakota officials warn of COVID-19 exposure at Sturgis" width="88" height="50">
			</a>
		</div>
	</div>
</div>
<!-- End Content Block 31 686 --> 
	                
                    
                
    </div>
<!-- End: E-SB-2 -->

            <!-- Begin Header Section Row -->
                
<!-- Start: E-SB-2 -->
	<div class="panel panel-default">
	        
       	            <!--- Inactive Content Block --->
	                
                    
                
    </div>
<!-- End: E-SB-2 -->

            <!-- Begin Header Section Row -->
                
        <div id="ADSPACE05" class=""><script>googletag.cmd.push(function() {googletag.display('ADSPACE05');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    
            <!-- Begin Header Section Row -->
                
<!-- Start: E-SB-2 -->
	<div class="panel panel-default">
	        
       	                  <a href="/spotcrime">
         <img class="img-responsive" style="margin-top:15px" src="/kaalimages/spotcrime-widget.png" 
            	title="Spot Crime Widget" 
                alt="Spot Crime Widget" />
      </a>

	                
                    
                
    </div>
<!-- End: E-SB-2 -->

        </div> 
        <!-- Close SideBar Column -->
    </div>
    <!-- Main Content and Sidebar Section -->
	<!-- Begin Footer Section Row -->	
    <div class="row">  
    
        <div id="ADSPACE06" class="ad-top-wrapper"><script>googletag.cmd.push(function() {googletag.display('ADSPACE06');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    
    </div>
	<!-- End Footer Section Row -->	
</div>
<!-- Close Main Container -->

<footer id="footer">
		
		<div class="container">
	<!-- Start: FOOTER -->
		<!-- Start Footer Link Section -->
		<div class="row">
   <div class="col-md-2 visible-md visible-lg">
      <ul class="list-unstyled list-lg-space"><li><a href="/index.shtml">NEWS</a></li></ul>
   </div>
   <div class="col-md-2 visible-md visible-lg">
      <ul class="list-unstyled list-lg-space"><li><a href="/weather/">WEATHER</a></li></ul>
   </div>
   <div class="col-md-2 visible-md visible-lg">
      <ul class="list-unstyled list-lg-space"><li><a href="/article/10209/">PROGRAMMING</a></li></ul>
   </div>
   <div class="col-md-2 visible-md visible-lg">
      <ul class="list-unstyled list-lg-space"><li><a href="/article/10206/">SPORTS</a></li></ul>
   </div>
   <div class="col-md-2 visible-md visible-lg"></div>
</div>
<div class="row">
   <div class="col-md-2 visible-md visible-lg">
      <ul class="list-unstyled list-lg-space"><li><a href="/article/10242/">ENTERTAINMENT</a></li></ul>
   </div>    
   <div class="col-md-2 visible-md visible-lg">
      <ul class="list-unstyled list-lg-space"><li><a href="/article/13106/" target="_blank">ABOUT</a></li></ul>
   </div>
   <div class="col-md-2 visible-md visible-lg">
      <ul class="list-unstyled list-lg-space"><li><a href="/article/12368/">CONTACT US</a></li></ul>
   </div>
   <div class="col-md-4" style="text-align:center;">
      <a href="/"><img alt="ABC 6 News" class="img-responsive" src="/assets/images/weblogos.png" /></a>
      <div class="addthis_inline_follow_toolbox" style="text-align-center"></div>
	     <script type="text/javascript" class="center-block" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-57daef8617aecc6a"></script>      
   </div>
</div>
		<!-- End Footer Link Section -->
		<hr>
		<!-- Start FCC Section -->
		<div class="row">
<div class="col-xs-12 text-center">
<p><b>
<a href="https://publicfiles.fcc.gov/tv-profile/kaal" target="_blank">FCC Public Inspection File</a>
</b></p>
<p style="color:white;"><b>Any person with disabilities who needs help accessing the FCC Public file should email <a href="mailto:news@kaaltv.com">news@kaaltv.com</a> or call (507) 288-7555</b></p>
<a href="https://hubbardbroadcasting.com/privacy-policy/?utm_source=kaal&utm_medium=link&utm_campaign=privacy-policy" target="_blank">Privacy Policy</a> | 
<a href="/pages/footer/terms-of-use.shtml">Terms of Use</a> | 
<a href="/pages/footer/dmca-notice.shtml">DMCA Notice</a> | 
<a href="https://hubbardbroadcasting.com/data-request/?site=kaal&utm_source=kaal&utm_medium=link&utm_campaign=data-request" target="_blank">Do Not Sell My Info</a> | 
<a href="/pages/footer/site-map.shtml">Site Map</a> |
<a href="/pages/footer/contest-rules.shtml">Contest Rules</a> |
<a href="/pages/footer/public-files.shtml">Public Files</a> | 
</p>

</div>
</div>
		<!-- End FCC Section -->
	<!-- End: FOOTER -->
	<div class="row">
		<div class="col-xs-12 text-center">
		<p style="color:#fff;">
		This website is not intended for users located within the European Economic Area.<br />
		&copy; <script>document.write(new Date().getFullYear());</script> KAAL-TV, LLC<br />
		A Hubbard Broadcasting Company</p>
		</div>
	</div>
	<script src="https://js.adsrvr.org/up_loader.1.1.0.js" type="text/javascript"></script>
<script type="text/javascript">
	ttd_dom_ready( function() {
		if (typeof TTDUniversalPixelApi === 'function') {
			var universalPixelApi = new TTDUniversalPixelApi();
			universalPixelApi.init("dzsq9wu", ["i11zcr9"], "https://insight.adsrvr.org/track/up");
		}
	});
</script>
</div>
        
</footer>
<script type="text/javascript">
  /********************************
   * FOR DEMO ONLY
   */
  $('a').on('click', function (e) {
    if ( $(this).prop('href') == '#') {
      e.preventDefault();
    }
  });
  /*********************************/
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"9e4de1d9fc","applicationID":"13487676","transactionName":"NlMEYhEFXkUEAEBdVw8ZM0QKS1VOBA5EWF0SGQ5ZDgEeRg0T","queueTime":0,"applicationTime":2,"atts":"GhQHFFkfTUs=","errorBeacon":"bam.nr-data.net","agent":"js-agent.newrelic.com\/nr-768.min.js"}</script>


	<!-- BEGIN: 2016-3rd-Party-Footer -->

<!-- Google Analytics -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21751680-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
	var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- End Google Analytics -->

<!-- NextMillennium Ads -->
<script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//nextmillennium.liqwid.net/?key=D85D-A6F1-B041-B88A'; var x=document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s,x);})();
</script>
<!-- End of NextMillennium Ads -->
<!-- Begin Taboola Tag -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

<!-- End Taboola Tag -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "15551634" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=15551634&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

<!-- Zeta LightBox -->
<script type="text/javascript">
  
       (function () {
        window.setTimeout(function() {
        var e = document.createElement('script'); e.type = 'text/javascript'; e.async = true;
        e.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'www.lightboxcdn.com/vendor/ec68e91b-d49a-45b1-9be7-52ca9f606139/lightbox_inline.js?mb=' + (new Date().getTime());
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(e, s);
        }, 500);
        })();
    
</script>
<!-- End Zeta LightBox -->

<!-- END: 2016-3rd-Party-Footer -->
	
  
</body> 
</html>

